Habilitar jQuery 1.9 en Drupal 7

Author Top
enzo

En algunas circunstancias necesitamos instalar en nuestros proyectos jQuery 1.9 o superior, el problema es que esta capacidad no esta disponible en la actualidad. lo mas cercano es jQuery  1.8 utilizando el módulo jQuery Update.

Pero siempre tenemos opciones si sabes algo del desarrollo de módulos en Drupal 7, haciendo reroll del parche provisto por el Issue Upgrade jquery 1.9 contra la versión 2.3-dev podremos alcanzar nuestro cometido.

Sin embargo jQuery 1.9 no es compatible con muchos módulos como Panels y Admin menu entre otros para lo cual quizas debamos aplicar algunos ajustes como en prestado en la entrada de blog Como activar el objeto $.browser si estas usando jQuery 1.9 en Drupal 7.

Para solucionar estos impases debemos hacer uso de una nueva funcionalidad que nos brinda la versión de jQuery Update 2.3-dev y que estará disponible en la versión 2.4, esta funcionalidad permite decidir que versión de jQuery ejecutar en la parte administrativa y también definir en que paginas especificas cargar la versión de jQuery de la sección administrativa.

Esta funcionalidad se puede apreciar en la siguiente imagen.

Adjunto puedes encontrar el parche y un zip con la versión ya funcional que puede usar bajo su propio riesgoTongue Out.

Espero que haya sido de su agrado.

bursa esc
bursa eskort
bursa escort bayan bursa travesti escort bursa merkez escort bursaescort bursa escort bayanlar alanya eskort bayan antalya bayan eskort havalimanı transfer